
Using AutoCAD 14 and AutoCAD 2000 with the MicroScribe 
 
Inputting 3D Data in AutoCAD R14 and AutoCAD 2000 
 

Configuring MicroScribe Utility Software 
MicroScribe Utility Software is a free utility from Immersion Corporation. It formats the XYZ data 
from the MicroScribe and emulates keyboard key presses to enter data into various programs 
able to accept keyboard data entry. The AutoCAD Format Strings in MicroScribe Utility Software 
will allow you to input 2D or 3D data with the MicroScribe. MicroScribe Utility Software may be 
downloaded from http://www.immersion.com/ 
 
Any questions about these directions may be sent to microscribe_tech@immersion.com 

 
To use MicroScribe Utility Software with AutoCAD: 
1. Launch MicroScribe Utility Software. 
2. Click on the Format Strings icon. 
3. From the Select Format list choose AutoCAD(3D) Format String. 
4. Verify that the format string is as follows: “%.4f,%.4f,%.4f\n” If it is not, follow 
instructions in the MicroScribe Utility Software help to change the format string to the one 
above. 
5. Click OK. 
6. Click on the Reference Frame icon. 
7. Select either the World Frame or Custom option. 

• World Frame uses the default reference frame the MicroScribe establishes on 
start up. 

• Custom allows the user to define where the origin and X- and Y-axes are in the 
physical workspace. For more information of Custom Reference Frames see 
the help files of MicroScribe Utility Software. 

 
Capturing 3D Data in AutoCAD 

 
To digitize a 3D polyline: 
1. From the Draw menu, click on 3D Polyline or type 3dpoly at the command line. 
2. Start digitizing the 3D polyline with the MicroScribe. 
3. To connect the 3D polyline to another object use the mouse to close the polyline. 
 
Once the points have been plotted, pressing the Enter key will end the command. 
 
Using a four-panel view port helps to see the data in 3D. 
 
To set-up multiple view ports: 
1. From the View menu choose Viewports or type vports at the command line. 
2. Select number of viewports desired. 
3. To modify the multiple view ports, click on the desired view port, then click on the View 
menu. 
4. Choose 3D Views, then click on the desired view to re-orient each view port. 

 
Along with the 3D polylines, the MicroScribe can also be used to create 3D splines. 
 

To digitize a 3D spline: 
1. From the Draw menu, click on Spline or type spline at the command line. 
2. Start digitizing points with the MicroScribe to create the spline, when completed press 
the Enter key. 
3. At the Specify start tangent prompt press Enter again, then at the Specify End tangent 
prompt, press the Enter key again to complete the spline and end the command. 

http://www.immersion.com/


 
The line command can be used to digitize a simple 3 dimensional line (edge). 
 

To digitize a 3D line: 
1. From the Draw menu click on Line or type line at the command line. 
2. Start digitizing points with the MicroScribe to create a line. 
3. When finished, press the Enter or Escape keys to end the command. 

 
Creating Circles 
The circle command cannot be used with the MicroScribe while using the AutoCAD (3D) Format 
String in MicroScribe Utility Software. This pertains to 3-point, 2-point, ttr, and centerline circles. 
To digitize circles the Format String in MicroScribe Utility Software must be changed to AutoCAD 
(2D). See the “Inputting 2D Data” section of this document for more information. 
 
Creating 3D Surfaces 
Using the Edge Surface Command you can create a 3D surface by selecting enclosed edges. 
These source edges must be connected in order for the command to work. 

 
To make a 3D surface: 
1. From the Draw menu select Surfaces, and choose Edge Surface, or type Edgesurf at 
the command line. 
2. Choose the appropriate edges or curves to create the desired surface. 
3. Note: using the Edge Surface command requires that you select exactly four edges or 
curves to create a 3dsurface. 

 
Using the Auto Plot Feature within MicroScribe Utility Software 
This feature allows users to capture data at defined intervals of distance. It is ideal for uniformly 
spacing points along a curve. It works well with the spline, line, and polyline command. For more 
information on using this feature see the help files of MicroScribe Utility Software.  
 
Please note: Auto Plot only works when the MicroScribe Mouse feature in MicroScribe Utility 
Software is OFF. 
 
Using the Scan Planes Feature within MicroScribe Utility Software 
The Scan Planes feature allows users to create 2D cross section curves of 3D objects. The user 
defines a series of virtual planes. Then, each time the MicroScribe stylus passes through one of 
the planes, data is collected. For more information on this feature see the help files of 
MicroScribe Utility Software. 



 
Inputting 2D Data In AutoCAD R14 and AutoCAD 2000 

 
Configuring MicroScribe Utility Software 
MicroScribe Utility Software is a free utility from Immersion Corporation. It formats the XYZ data 
from the MicroScribe and emulates keyboard key presses to enter data into various programs 
able to accept keyboard data entry. The AutoCAD (2D) Format String in MicroScribe Utility 
Software will allow you to input 2D data with the MicroScribe. MicroScribe Utility Software may be 
downloaded from: http://www.immersion.com/ 
 

To use MicroScribe Utility Software with Auto CAD: 
1. Launch MicroScribe Utility Software. 
2. Click on the Format Strings icon. 
3. From the Select Format list choose AutoCAD (2D) Format String. 
4. Verify that the format string is as follows:”%.4f,%.4f\n”  If it is not, follow instructions in 
the MicroScribe Utility Software help to change the format string to the one above. 
5. Click OK. 
6. Click on the Reference Frame icon, the third from the left. 
7. Select either the World Frame or Custom option. 

• World Frame uses the default reference frame the MicroScribe establishes on 
start up. 

• Custom allows the user to define where the origin and X- and Y-axes are in the 
physical workspace. For more information of Custom Reference Frames see the 
help files of MicroScribe Utility Software. 

 
Capturing 2D Data in AutoCAD 
 
Creating Splines 
Using the spline command with the MicroScribe creates an interpolated curve when plotting 
points with the MicroScribe. The curve will be completed once the points and the start tangent 
and end tangent have been entered. Pressing the Enter key at the "Enter start tangent" prompt 
and the "Enter end tangent" prompt will create the desired curve. 
 

To create a 2D spline: 
1. From the Draw menu, click on Spline or type spline at the command line. 
2. At the specify first point (object) prompt, use the MicroScribe or mouse to select a start 
point for the spline. 
3. Continue picking points as desired until finished. 
4. At the Specify start tangent prompt press Enter again, then at the Specify End tangent 
prompt, press the Enter key again to end the command and complete the spline. 

 
Creating Rectangles 
The MicroScribe can be used to input the two opposing corners of a rectangle: 
 

To create a 2D rectangle: 

 
1. From the Draw menu click on Rectangle or type rectangle at the command prompt. 
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2. Digitize the first point (corner) with the MicroScribe, and then digitize the second point 
(opposite corner) to complete the rectangle. 
3. (See figure above) 

 
Creating Circles 
Using the Circle command to input circles, requires you to first choose a type: 3-point circle, 2-
point circle, tangent tangent radius circle, or centerline circle.  
 
You can use the MicroScribe to create a 3-point circle by placing three approximately evenly 
spaced points on the circle being digitized. 
 

To create a 3-point circle: 

 
1. From the Draw menu choose Circle or type circle from the command line. 
2. From the circle specify… prompt enter 3P and press the Enter key. 
3. Digitize 3 points approximately evenly spaced on the circle (See figure above). 

 
The 2-point circle is exactly like the 3-point circle with the exception that it requires only two 
points. It is important to take these points at the diameter so that the circle will have the same 
dimensions as the original. 
 

To create a 2-point circle: 

 
1. From the Draw menu choose Circle or type circle at the command line. 
2. From the circle specify… prompt enter 2P and press the Enter key. 
3. Digitize 2 points approximately at the diameter of the circle (See figure above).  

 
The tangent tangent radius circle can only be used with the mouse. This command uses two 
tangents; either being arcs, lines, or circles, and requires a radius to complete the circle. 
 

To create a tangent radius circle: 
1. From the Draw menu choose Circle or type circle from the command line. 
2. From the circle specify… prompt enter Ttr and press the Enter key. 
3. From the Specify point on object for first tangent of circle prompt digitize the proper 
point for tangency. 
4. From the Specify point on object for second tangent of circle prompt digitize another 
point for tangency. 
5. At the Specify radius of circle prompt enter the required radius; press the Enter key, 
then the tangent circle will be complete. 

 
The centerline circle command requires the center point and the radius of the circle for creation. 
Using the MicroScribe simplifies the placement and size of such a circle. The centerline 



command requires you to place the tip of the stylus at the center, click the left button, then place 
the stylus at the radius of the circle and click the left button once more to complete the circle. 
 

To create a centerline circle: 
1. From the Draw menu choose Circle or type circle at the command line. 
2. From the circle specify… prompt digitize the center point of the circle, and then digitize 
a point at the perimeter of the circle. 

 
Creating Ellipses 
Using the Ellipse command with the MicroScribe differs from its use with the mouse. To plot the 
ellipse with the mouse, AutoCAD asks for two axis endpoints and another axis or rotation point to 
create the ellipse. 
 
An ellipse can be created with the MicroScribe by plotting three points: two along the edge of the 
ellipse near the center and one perpendicular to the first two, also along the edge of the ellipse. 
 
You can also plot two points at the parabolic ends of the ellipse and one at the center edge to 
create the original ellipse. 

 
To create an ellipse: 
1. From the Draw menu choose Ellipse or type Ellipse at the command line. (See figure 
above) 
2. At the Specify axis endpoint of ellipse prompt digitize a point at the parabolic end of the 
ellipse (point 1). 
3. At the Specify other endpoint of axis prompt digitize a point at the other parabolic end 
of the ellipse (point 2). 
4. At the Specify distance to other axis or [Rotation] prompt digitize a point at the edge 
but at the center of the ellipse, (point 3) to complete the ellipse. 

 
Creating Arcs 

 
To create an arc: 
1. From the Draw menu choose Arc, and then select the desired type of arc (e.g.: start, 
center, end). 
2. You can also type arc at the command line (this will automatically put you into the 3 
point option). 
3. At the prompt digitize first point (according to type of Arc selected). 
4. Continue to digitize points as prompted. 
5. After the third point is digitized, the arc will be completed and the command will end. 

 
Creating arcs from the ellipse command is similar to creating a standard ellipse. 
 

To create an arc using the ellipse feature: 
1. From the Draw menu choose Ellipse or type Ellipse at the command line 
2. Type in a or arc at the Specify axis endpoint of ellipse or [Arc/center] prompt. 
3. At the Specify axis endpoint of elliptical arc prompt digitize a point at the parabolic end 
of the ellipse (see step 2 in creating an ellipse above). 



4. At the Specify other endpoint of axis prompt digitize a point at the other parabolic end 
of the ellipse. (See step 3 in creating an ellipse above). 
5. At the Specify distance to other axis or [Rotation] prompt digitize a point at the edge 
but at the center of the ellipse to complete the ellipse. (See step 4 in creating an ellipse 
above). 
6. At the Specify start angle or [Parameter] prompt digitize a point to define the starting 
point of the arc. 
7. At the Specify end angle or [Parameter/Included angle] prompt digitize a point to define 
the end point of the arc. 

 
Once the specified end angle (end point) has been digitized, and the arc will be complete. 
Using the mouse in conjunction with the MicroScribe: 
It is possible to use your mouse in conjunction with the MicroScribe during all AutoCAD 
commands. This is very helpful when you need to snap to exact points. 
 

1. Type or use the menus to activate the desired AutoCAD command. 
2. Use the mouse along with any snap feature to select a point. 
3. You may then use the MicroScribe or the mouse interchangeably to select the 
remainder of the points. 
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